Fork Clansuite on GitHub

Internet Relay Chat - Logs for #koch
Collected by k-logbot on chat.freenode.net

IRC Log for Samstag, 26. Mai 2012

  1. 1: [0:01] -jubii2.dk.quakenet.org- on 3 ca 2(4) ft 20(20) tr
  2. 2: [0:01] * cslogbot (~PircBot@server.jakoch.de) has joined #clansuite
  3. 3: [0:04] <jakoch> so, ich bin raus.. testen wird verschoben. n8
  4. 4: [1:51] * Rikku`on (~Daniel@31.16.179.253) Quit (Read error: EOF from client)
  5. 5: [7:19] * CIA-1 (~CIA@cia.atheme.org) Quit (Ping timeout)
  6. 6: [7:20] * CIA-1 (~CIA@cia.atheme.org) has joined #clansuite
  7. 7: [11:29] * Rikku`on (~Daniel@31.16.179.253) has joined #clansuite
  8. 8: [11:30] <Rikku`on> o/
  9. 9: [11:47] <jakoch> \o
  10. 10: [12:01] <Rikku`on> hey, war gestern abend relativ busy und nicht mehr am pc
  11. 11: [12:01] <Rikku`on> hätte jetzt zeit das zu testen....
  12. 12: [12:02] <jakoch> jo, kein ding. ok, dann werd ich das jetzt mal packen
  13. 13: [12:02] <Rikku`on> kk
  14. 14: [12:06] <jakoch> http://clansuite.com/ftp/wpnxm-scp.zip
  15. 15: [12:08] <jakoch> das ist gegen shared libraries gelinkt
  16. 16: [12:08] <jakoch> ich hoffe die beiden qt files sind ausreichend damit das startet
  17. 17: [12:10] <Rikku`on> kann nicht gestartet werden weil mingwm10.dll aufm dem computer fehlt
  18. 18: [12:10] <jakoch> ah ok
  19. 19: [12:10] <jakoch> mom
  20. 20: [12:12] <jakoch> ok, saug nochmal
  21. 21: [12:13] <Rikku`on> nope
  22. 22: [12:14] <Rikku`on> also immer noch der fehler
  23. 23: [12:14] <jakoch> http://clansuite.com/ftp/mingwm10.dll
  24. 24: [12:15] <Rikku`on> wo soll die rein
  25. 25: [12:15] <Rikku`on> system32?
  26. 26: [12:16] <jakoch> n�, da wo die exe is
  27. 27: [12:16] <Rikku`on> libgcc_s_dw2-1.dll fehlt
  28. 28: [12:17] <jakoch> oh mann, das geht jetzt fr�hlich so weiter bis wir alle klamotten zusammen haben
  29. 29: [12:17] <Rikku`on> ^^
  30. 30: [12:18] <jakoch> http://clansuite.com/ftp/libgcc_s_dw2-1.dll
  31. 31: [12:19] <jakoch> 12mb abh�ngigkeiten f�r 283kb programm
  32. 32: [12:19] <jakoch> ich muss unbedingt rausbekommen, wie man bei qt statisch linkt und die abh�ngigkeiten rauswirft, um die datei m�glichst klein zu bekommen
  33. 33: [12:20] <Rikku`on> ^^
  34. 34: [12:20] <Rikku`on> programm startet
  35. 35: [12:20] <Rikku`on> aber mit drei fehler
  36. 36: [12:20] <jakoch> nicht alle pushbuttons sind verlinkt
  37. 37: [12:20] <jakoch> was kommen da f�r fehler?
  38. 38: [12:21] <Rikku`on> das die prozesse nicht gestartet weren können, liegt aber wahrscheinlich daran das es die nicht gibt ^^
  39. 39: [12:22] <jakoch> ja, im moment ist autostarten aller prozesse beim start der tray app an
  40. 40: [12:23] <jakoch> sp�ter wird das per configuration einstellbar sein, ob beim starten des scp auch der rest gestartet werden soll
  41. 41: [12:24] <Rikku`on> soll ich da noch etwas testen, oder ging es nur darum ob es jetzt überhaupt startet?
  42. 42: [12:25] <jakoch> jo, am besten w�re nat�rlich, wenn du das in den serverstack kopierst, damit die daemons steuerbar sind
  43. 43: [12:25] <Rikku`on> dann muss ich den mal eben runterladen
  44. 44: [12:26] <jakoch> argz
  45. 45: [12:26] <jakoch> warte ich geb dir nen build aus der develop branch
  46. 46: [12:26] <Rikku`on> kk
  47. 47: [12:28] <jakoch> ansonsten gehts um basis tests.. gehn die buttons, doppelstart, geht der tray auf, zu, fenster auf zu, close, quit etc
  48. 48: [12:28] <Rikku`on> der git for windows autoupdater klappt wunderbar, merke ich gerade
  49. 49: [12:28] <Rikku`on> oki
  50. 50: [12:29] <jakoch> http://clansuite.com/ftp/WPMXM-0.3.0-Setup.exe
  51. 51: [12:30] <Rikku`on> The requested URL /ftp/WPMXM-0.3.0-Setup.exe was not found on this server.
  52. 52: [12:30] <jakoch> vertippert
  53. 53: [12:30] <jakoch> http://clansuite.com/ftp/WPMXN-0.3.0-Setup.exe
  54. 54: [12:31] <jakoch> http://clansuite.com/ftp/WPNXM-0.3.0-Setup.exe
  55. 55: [12:31] <jakoch> :)
  56. 56: [12:31] <jakoch> NMN
  57. 57: [12:31] <jakoch> NIN
  58. 58: [12:32] <jakoch> http://www.youtube.com/watch?feature=player_embedded&v=ljbBayiWglg
  59. 59: [12:33] <Rikku`on> also beim entpacken solltest du im installer schreiben das die packete entpackt werden und das einige zeit in anspruch nehmen kann
  60. 60: [12:34] <Rikku`on> ich denke immer der hat sich aufgehängt
  61. 61: [12:34] <jakoch> das problem ist bereits eingetragen: https://github.com/jakoch/WPN-XM/issues/17
  62. 62: [12:34] <Rikku`on> kk
  63. 63: [12:35] <jakoch> das problem ist den status vom unzip �ber stdout reinzubekommen, weil es ja ein anderer prozess ist
  64. 64: [12:38] <jakoch> aber du hast recht, bis das behoben ist, ist ne textmeldung angebracht
  65. 65: [12:42] <jakoch> in welchem style wird das angezeigt?
  66. 66: [12:43] <Rikku`on> ??
  67. 67: [12:43] <jakoch> also der tray und das fenster.. werden die in deinem normalen windows style angezeogt?
  68. 68: [12:44] <Rikku`on> jo
  69. 69: [12:44] <jakoch> ok
  70. 70: [12:45] <Rikku`on> die links zu den tool funktionieren nicht
  71. 71: [12:45] <Rikku`on> sind falsch adressiert
  72. 72: [12:47] <jakoch> ok.. wie muss ich ab�ndern? /localhost/www/ statt /localhost/webinterface/?
  73. 73: [12:49] <Rikku`on> warte, jetzt funzt der webserver nicht mehr
  74. 74: [12:51] <jakoch> die buttons d�rfen auch nur angezeigt werden, wenn die tools auch installiert sind
  75. 75: [12:51] <jakoch> daf�r muss ich noch nen check einbauen
  76. 76: [12:52] <Rikku`on> also phpinfo linkt nach http://localhost/webinterface/phpinfo da fehlt noch das *.php am ende
  77. 77: [12:53] <Rikku`on> php my admin linkt nach http://localhost/webinterface/phpmyadmin es gibt ja aber ein vhost muss also nach http://localhost/phpmyadmin/ verlinkt werden
  78. 78: [12:53] <Rikku`on> das gleiche für webgrind
  79. 79: [12:55] <Rikku`on> der status (grüner punkt wird nicht angezeigt) obwohl die programme laufen
  80. 80: [12:55] <jakoch> nich so schnell^^
  81. 81: [12:55] <jakoch> ok, phpinfo extension angeh�ngt
  82. 82: [12:56] <jakoch> es gibt einen vhost f�r phpmyadmin? wo kommt der her?
  83. 83: [12:56] <Rikku`on> hab den server aber vorher durch die start-wpnxm.exe
  84. 84: [12:57] <Rikku`on> ah, das ist ja gar kein vhost
  85. 85: [12:57] <jakoch> ich w�rde auf http://localhost/www/phpmyadmin verlinken, funzt das bei dir?
  86. 86: [12:57] <Rikku`on> die verzeichnisse liegen im root
  87. 87: [12:57] <Rikku`on> nope
  88. 88: [12:57] <Rikku`on> weil localhost root ist
  89. 89: [12:58] <Rikku`on> deswegen auch localhost/phpmyadmin
  90. 90: [12:58] <jakoch> .../localhost/www gibts aber?
  91. 91: [12:58] <jakoch> .../localhost/phpmyadmin auch?
  92. 92: [12:58] <Rikku`on> localhost/www gibbet nicht
  93. 93: [12:59] <jakoch> jau, konfusion meinerseits
  94. 94: [12:59] <jakoch> www is der root folder vom localhost
  95. 95: [12:59] <Rikku`on> right
  96. 96: [13:00] <Rikku`on> der button "Browser" linkt auch auf localhost/www welches es ja nicht gibt
  97. 97: [13:01] <jakoch> da reicht dann auch http://localhost
  98. 98: [13:01] <jakoch> ok
  99. 99: [13:01] <Rikku`on> jap
  100. 100: [13:01] <jakoch> explorer �ffnen geht noch nich
  101. 101: [13:02] <jakoch> dann nochmal die geschichte mit den status lampen
  102. 102: [13:03] <jakoch> am besten alles aus machen - zur not auch stop-wpnxm.exe ausf�hren, das ding is radikal
  103. 103: [13:04] <jakoch> und dann �ber den tray starten und stoppen und dort die lampen kontrollieren.. und der status muss auch im hauptfesnter gewechselt werden
  104. 104: [13:05] <jakoch> und dann r�ckw�rts: also die steuerung ausm hauptfenster, aktualisiert eigenen status und die lampen im tray
  105. 105: [13:06] <jakoch> ach und .. am besten auch mal den prozess manuell abschie�en und schauen ob die lampe ausgeht
  106. 106: [13:06] <Rikku`on> w00t
  107. 107: [13:06] <jakoch> �ber task-manager, beenden
  108. 108: [13:06] <Rikku`on> also ich hab prozesse aus
  109. 109: [13:06] <jakoch> ok
  110. 110: [13:06] <Rikku`on> starte über tray
  111. 111: [13:07] <Rikku`on> keine lampe an obwohl nginx und php-cgi prozesse gestartet sind
  112. 112: [13:07] <Rikku`on> mysql startet nicht
  113. 113: [13:07] <Rikku`on> dann stoppe ich alle prozesse über tray
  114. 114: [13:08] <Rikku`on> bekomme die fehlermeldung PHP Error. The process crashed som time after starting successfully
  115. 115: [13:08] <jakoch> d.h. beim stoppen vom php daemon crashed das ding?
  116. 116: [13:09] <Rikku`on> das tray läuft weiter
  117. 117: [13:09] <jakoch> achso ok
  118. 118: [13:10] <jakoch> d.h. er schreibt "php process crashed" beim stopp clicken und l�uft weiter
  119. 119: [13:10] <Rikku`on> wenn ich dann alle daemon wieder starte leuchtet auch das lämpchen
  120. 120: [13:10] <Rikku`on> jap
  121. 121: [13:10] <jakoch> ahh, das is doch gut
  122. 122: [13:11] <jakoch> die l�mpchen leuchten im tray und im hauptfenster, ja?
  123. 123: [13:11] <jakoch> dann bleibt also das problem, das beim starten der lampenstatus nicht stimmt
  124. 124: [13:12] <Rikku`on> wenn ich einzelne prozesse aus dem task manager kicke, geht die lampe auch aus
  125. 125: [13:12] <jakoch> ok..dann wei� ich wo der fehler liegt.. runAll()
  126. 126: [13:13] <jakoch> mariadb startet nicht..
  127. 127: [13:13] <Rikku`on> wenn ich dann über den tray den prozess wieder starte (in dem fall nginx) funktioniert der nicht mehr
  128. 128: [13:15] <Rikku`on> jau und die maria ist total teilnahmslos
  129. 129: [13:15] <jakoch> ja, die maria is auch doof
  130. 130: [13:16] <jakoch> irgendwie ist da der wurm drin, seit dem versionsupdate
  131. 131: [13:17] <Rikku`on> warum eigentlich mariadb und nicht mysql direkt?
  132. 132: [13:17] <jakoch> uhm, na weil mariadb der nachfolger von mysql is
  133. 133: [13:18] <jakoch> der chefentwickler is doch raus bei mysql
  134. 134: [13:18] <jakoch> d.h. weg von oracle und macht das ding unter mariadb weiter
  135. 135: [13:19] <Rikku`on> ahh ok
  136. 136: [13:19] <jakoch> also defakto ist das ein 100% mysql mit anderem namen und ein paar mehr features
  137. 137: [13:20] <jakoch> und nat�rlich GNU GPL v2
  138. 138: [13:20] <Rikku`on> kk
  139. 139: [13:21] <jakoch> so dann werd ich jetzt issues anlegen..
  140. 140: [13:22] <jakoch> php daemon crash is drin
  141. 141: [13:24] <jakoch> status leds beim starten updaten is drin
  142. 142: [13:26] <jakoch> maria startet nich is drin
  143. 143: [13:27] <jakoch> ok, die tools links sind aktualisiert
  144. 144: [13:27] <jakoch> da fehlt noch der check obs das tool gibt
  145. 145: [13:28] <jakoch> ok, is auch drin
  146. 146: [13:28] <jakoch> so, hab ich was vergessen?
  147. 147: [13:28] <Rikku`on> das der server nicht funktioniert obwohl der prozess läuft ^^
  148. 148: [13:28] <jakoch> ?
  149. 149: [13:29] <jakoch> nginx an ? php an?
  150. 150: [13:29] <Rikku`on> jap
  151. 151: [13:29] <jakoch> und localhost geht nicht?
  152. 152: [13:29] <Rikku`on> right
  153. 153: [13:30] <jakoch> was sagt denn \bin\nginx\logs\error.log?
  154. 154: [13:31] <jakoch> bzw. \logs\error.log
  155. 155: [13:33] <jakoch> ich bin erstmal was essen
  156. 156: [13:33] <Rikku`on> 2012/05/26 13:33:01 [error] 3752#1960: *3 "C:\server\bin\nginx/www/webinterface/index.php" is not found (3: FormatMessage() error:(15105)), client: 127.0.0.1, server: localhost, request: "GET /webinterface/ HTTP/1.1", host: "localhost", referrer: "http://localhost/"
  157. 157: [13:33] <Rikku`on> 2012/05/26 13:33:01 [error] 3752#1960: *3 CreateFile() "C:\server\bin\nginx/www/favicon.ico" failed (3: FormatMessage() error:(15105)), client: 127.0.0.1, server: localhost, request: "GET /favicon.ico HTTP/1.1", host: "localhost"
  158. 158: [13:34] <Rikku`on> mehr sagt der nicht
  159. 159: [13:34] <jakoch> hmm
  160. 160: [13:34] <jakoch> C:\server\bin\nginx/www/webinterfac
  161. 161: [13:34] <jakoch> e/index.php
  162. 162: [13:34] <jakoch> das sieht komisch aus, die slashes sind nich original.. da hat doch einer b-teile verbaut
  163. 163: [13:36] <jakoch> wieso �berhaupt bin\nginx? da muss c:\server\www\webinterface stehn
  164. 164: [13:36] <jakoch> also c:\<installfolder>\www\webinterface stehn
  165. 165: [13:36] <Rikku`on> das stimmt
  166. 166: [13:37] <jakoch> gut, da ich nginx conf nich ge�ndert hab, hat nginx was ge�ndert...
  167. 167: [13:37] <Rikku`on> wie gesagt, nach dem man den prozess neu startet, da muss einer dann etwas verdeht haben
  168. 168: [13:38] <jakoch> ..\bin\nginx\conf\nginx.conf
  169. 169: [13:40] <jakoch> welche version von nginx? 1.2?
  170. 170: [13:41] <Rikku`on> jap
  171. 171: [13:41] <jakoch> hmm... muss ich mal changelog durchlesen, was in der cfg ge�ndert wurde
  172. 172: [13:41] <jakoch> <- essen
  173. 173: [13:41] <Rikku`on> gudn
  174. 174: [14:09] <jakoch> danke, re
  175. 175: [14:10] <jakoch> ich bin erstmal off, falls du noch bugs findest, ab in den tracker damit
  176. 176: [14:10] <jakoch> bis sp�ter
  177. 177: [14:17] * wpnxm-bot (~wpnxm-bot@sh2.rs.github.com) has joined #clansuite
  178. 178: [14:17] <wpnxm-bot> [WPN-XM] jakoch pushed 3 new commits to develop: https://github.com/jakoch/WPN-XM/compare/1d4c580...66e1d70
  179. 179: [14:17] <wpnxm-bot> [WPN-XM/develop] added/corrected global and local include comments - jakoch
  180. 180: [14:17] <wpnxm-bot> [WPN-XM/develop] connected more pushButtons to functions - jakoch
  181. 181: [14:17] <wpnxm-bot> [WPN-XM/develop] fixed tool links - jakoch
  182. 182: [14:17] * wpnxm-bot (~wpnxm-bot@sh2.rs.github.com) has left #clansuite
  183. 183: [19:46] * Rikku`on (~Daniel@31.16.179.253) Quit (Read error: Connection reset by peer)

Links of Samstag, 26. Mai 2012

1) https://github.com/jakoch/WPN-XM/compare/1d4c580...66e1d70
2) http://localhost/"
3) http://localhost
4) http://localhost/www/phpmyadmin
5) http://localhost/webinterface/phpmyadmin
6) http://localhost/phpmyadmin/
7) http://localhost/webinterface/phpinfo
8) https://github.com/jakoch/WPN-XM/issues/17
9) http://www.youtube.com/watch?feature=player_embedded&v=ljbBayiWglg
10) http://clansuite.com/ftp/WPNXM-0.3.0-Setup.exe
11) http://clansuite.com/ftp/WPMXN-0.3.0-Setup.exe
12) http://clansuite.com/ftp/WPMXM-0.3.0-Setup.exe
13) http://clansuite.com/ftp/libgcc_s_dw2-1.dll
14) http://clansuite.com/ftp/mingwm10.dll
15) http://clansuite.com/ftp/wpnxm-scp.zip

These logs were automatically created by k-logbot on chat.freenode.net using the Clansuite IRC LogBot. Find the project at Github.