Fork Clansuite on GitHub

Internet Relay Chat - Logs for #koch
Collected by k-logbot on chat.freenode.net

IRC Log for Montag, 11. Juni 2012

  1. 1: [0:01] -jubii2.dk.quakenet.org- on 3 ca 2(4) ft 20(20) tr
  2. 2: [0:01] * cslogbot (~PircBot@server.jakoch.de) has joined #clansuite
  3. 3: [0:01] * Topic is 'All open WPM-XM issues are cash rewarded bounties! https://github.com/jakoch/WPN-XM/issues Contact me for the working and payment procedure!'
  4. 4: [0:01] * Set by jakoch on Wed May 30 15:42:11 CEST 2012
  5. 5: [0:32] * wpnxm-bot (~wpnxm-bot@sh3.rs.github.com) has joined #clansuite
  6. 6: [0:32] <wpnxm-bot> [WPN-XM] jakoch pushed 1 new commit to develop: https://github.com/jakoch/WPN-XM/commit/3d5eaef33a4f3f6330feaa5bc704db1ea1bbc091
  7. 7: [0:32] <wpnxm-bot> [WPN-XM/develop] added settings, setting. settingsTable - jakoch
  8. 8: [0:32] * wpnxm-bot (~wpnxm-bot@sh3.rs.github.com) has left #clansuite
  9. 9: [6:35] * CIA-1 (~CIA@cia.atheme.org) Quit (Signed off)
  10. 10: [6:49] * CIA-1 (~CIA@cia.atheme.org) has joined #clansuite
  11. 11: [9:46] * PwNu|Yosh (~Yosh@24.186.225.42) Quit (Ping timeout)
  12. 12: [12:14] * wpnxm-bot (~wpnxm-bot@sh2.rs.github.com) has joined #clansuite
  13. 13: [12:14] <wpnxm-bot> [WPN-XM] jakoch pushed 3 new commits to develop: https://github.com/jakoch/WPN-XM/compare/3d5eaef...09b5ab5
  14. 14: [12:14] <wpnxm-bot> [WPN-XM/develop] removed qdebug stmt - jakoch
  15. 15: [12:14] <wpnxm-bot> [WPN-XM/develop] added QT_BEGIN_NAMESPACE and QT_END_NAMESPACE to class forward declarations - jakoch
  16. 16: [12:14] <wpnxm-bot> [WPN-XM/develop] added settings to pro - jakoch
  17. 17: [12:14] * wpnxm-bot (~wpnxm-bot@sh2.rs.github.com) has left #clansuite
  18. 18: [12:14] * Rikku`on (~Daniel@31.16.179.253) has joined #clansuite
  19. 19: [12:14] <Rikku`on> o/
  20. 20: [12:19] <jakoch> hey
  21. 21: [13:40] <Rikku`on> http://de.wikipedia.org/wiki/Polyphasischer_Schlaf
  22. 22: [13:40] <Rikku`on> der uebermann bekommt aber echt wenig schlaf
  23. 23: [13:40] <Rikku`on> hat aber viel vom tag :D
  24. 24: [13:41] <Rikku`on> ich bin eher so die mischung aus biphasic und monophasic, also 8 sunden und der nacht und so 2 mal 1 std. nickerchen am an tag ^^
  25. 25: [13:42] <Rikku`on> aber 20 min schlaf? ... solange brauch ich allein schon um einzuschlafen ^^
  26. 26: [13:44] <jakoch> es gab mal einen,hmm
  27. 27: [13:44] <jakoch> der hat sich zum schlafen immer mitm l�ffel in der hand in nen sessel gesetzt
  28. 28: [13:45] <jakoch> kurz vorm einschlafen, f�llt das teil aus der hand.. das soll sehr erfrischend sein
  29. 29: [13:45] <jakoch> ich habe keine zeit f�r sowas
  30. 30: [13:45] <jakoch> :)
  31. 31: [13:47] <jakoch> ich w�rde gerne wpnxm 0.3.0 releasen, bekomme aber den application close bug nicht weg
  32. 32: [13:47] <Rikku`on> das ist doof. konntest du ihn den reproduzieren?
  33. 33: [13:48] <jakoch> ja
  34. 34: [13:49] <jakoch> http://codepad.org/d0kWPZvi
  35. 35: [13:54] <Rikku`on> immerhin
  36. 36: [13:55] <jakoch> ?
  37. 37: [13:56] <Rikku`on> immerhin kannst du den bug reproduzieren
  38. 38: [13:56] <Rikku`on> wenn das das nicht könntest wäre es schwer(er) ihn zu beheben
  39. 39: [13:57] <Rikku`on> also lösung empfehle ich: "die app nicht zu schließen"
  40. 40: [13:57] <Rikku`on> ich weiß, ich bin keine hilfe :D
  41. 41: [14:00] <jakoch> ok, ich schreibs in die issue liste, ich finde ihn nich, wird ein bounty bug
  42. 42: [14:03] * wpnxm-bot (~wpnxm-bot@sh3.rs.github.com) has joined #clansuite
  43. 43: [14:03] <wpnxm-bot> [WPN-XM] jakoch pushed 1 new commit to develop: https://github.com/jakoch/WPN-XM/commit/e5d248cbb91a0c00a48e025aa4a79d68a034f98a
  44. 44: [14:03] <wpnxm-bot> [WPN-XM/develop] workaround for bug: "clicking ui_pushButton_Close calls qApp quit() and crashes" - jakoch
  45. 45: [14:03] * wpnxm-bot (~wpnxm-bot@sh3.rs.github.com) has left #clansuite
  46. 46: [14:10] <jakoch> so.. release fertig machen
  47. 47: [14:12] <Rikku`on> gl
  48. 48: [14:52] <jakoch> k�nntest du bitte mal das scp testen? http://clansuite.com/ftp/wpn-xm-scp-0.3.0.zip
  49. 49: [14:53] <jakoch> geht darum, ob ich alle dlls erwischt hab
  50. 50: [14:54] <Rikku`on> jo
  51. 51: [14:57] <Rikku`on> also wenn man das scp anmacht sind alle stati grün obwohl kein process läuft (hab sogar den server vorher gelöscht, der ist also garnicht da)
  52. 52: [14:58] <jakoch> aber alle dlls sind da und es startet?
  53. 53: [14:58] <jakoch> der bug geh�rt zum release
  54. 54: [14:59] <Rikku`on> jo, starten tut es
  55. 55: [15:00] <jakoch> der led status im mainwindow l�sst sich nur schwer mit dem tray status synchronisieren, zumindest geht es nicht beim startup
  56. 56: [15:01] <jakoch> wenn das scp im server folder liegt, sollte allerdings alles korrekt sein
  57. 57: [15:04] <jakoch> so letzte runde fehler finden im installer: https://github.com/downloads/jakoch/WPN-XM/WPNXM-0.3.0-Setup.exe
  58. 58: [15:06] <Rikku`on> wenn man den uninstaller ausführt, bleiben nach der deinstallieren noch die die ordner bin/logs/temp/www im ordner samt inhalt
  59. 59: [15:09] <jakoch> ok, is eingetragen
  60. 60: [15:10] <Rikku`on> installation läuft durch
  61. 61: [15:11] <Rikku`on> server running
  62. 62: [15:11] <jakoch> hmm.. zieht er auch das scp?
  63. 63: [15:12] <Rikku`on> hm... muss ich nochmal installieren, weiss nicht mehr ob ich das manuell da reinkopiert habe oder nicht
  64. 64: [15:12] <Rikku`on> mom
  65. 65: [15:13] <jakoch> stop
  66. 66: [15:13] <jakoch> ne, er zieht es nich,
  67. 67: [15:13] <jakoch> neues build kommt
  68. 68: [15:14] <Rikku`on> kk
  69. 69: [15:15] <Rikku`on> wenn man das scp quited, bleibt das try icon in der task bar und verschwindet erst wenn man mit der maus drüberfährt
  70. 70: [15:17] <jakoch> ok, gut gesehn. da muss noch icon hide, bevor app quit rein
  71. 71: [15:24] <jakoch> updated https://github.com/downloads/jakoch/WPN-XM/WPNXM-0.3.0-Setup.exe
  72. 72: [15:29] <Rikku`on> wo soll das scp liegen?
  73. 73: [15:29] <Rikku`on> in welchem ordner?
  74. 74: [15:30] <jakoch> top level
  75. 75: [15:30] <Rikku`on> nope, da isch nüschts
  76. 76: [15:33] <jakoch> unklar.. download is da: http://wpn-xm.org/files/wpn-xm-scp-0.3.0.zip
  77. 77: [15:33] <jakoch> k�nnte h�chtens das unzip fehlschlagen
  78. 78: [15:33] <jakoch> brb 20min
  79. 79: [15:40] <Rikku`on> hm.. muss wohl so sein, definitiv nicht da
  80. 80: [15:41] <Rikku`on> während der installation kommt das mal http://i.imgur.com/ZxDkO.png
  81. 81: [15:41] <Rikku`on> aber mysqld läuft trotzdem
  82. 82: [15:59] <jakoch> re
  83. 83: [15:59] <jakoch> also wpnxmscp fehlt
  84. 84: [16:00] <jakoch> mysql.. ok, das is w�hrend des l�schens von dateien, sch�tze mal ein typo
  85. 85: [16:00] <Rikku`on> wb
  86. 86: [16:01] <jakoch> k�nntest du mal nen screeny vom /server/bin/mariadb/bin dir machen?
  87. 87: [16:02] <jakoch> ahhh.. habs schon
  88. 88: [16:02] <jakoch> del /q /f "%MYSQL_DIR%\bin\aria_ftpdump.exe"
  89. 89: [16:02] <jakoch> die datei nennt sich aria_ftdump.exe
  90. 90: [16:02] <jakoch> ohne p
  91. 91: [16:06] <Rikku`on> mariadb läßt sich über das scp nicht starten
  92. 92: [16:08] <Rikku`on> wenn alle prozesse über die start-wpnxm.exe gestartet werden, lassen sie sich nicht vom dem scp beenden
  93. 93: [16:09] <Rikku`on> wenn die prozesse schon laufen, werden neue prozesse hinzugefügt wenn man über das scp (nginx/php) startet
  94. 94: [16:12] <Rikku`on> irgendwie ist das webinterface hinüber, auf die phpinfo komm ich erst nachdem ich einmal phpmyadmin besucht habe, danach sind die links zu configuration und projekt & tools defekt und zeigen nur noch die phpinfo an
  95. 95: [16:13] <jakoch> geht gleich los, kurzer restart
  96. 96: [16:20] <jakoch> re
  97. 97: [16:34] <jakoch> den fehler mit dem webinterface kann ich nicht reproduzieren.. was is da genau los?
  98. 98: [17:13] <Rikku`on> ich mach mal ne kleine fotostrecke
  99. 99: [17:13] <Rikku`on> http://i.imgur.com/K0YS1.png
  100. 100: [17:14] <Rikku`on> http://i.imgur.com/8KcJZ.png
  101. 101: [17:14] <Rikku`on> nichts passiert
  102. 102: [17:14] <Rikku`on> http://i.imgur.com/SoKc5.png
  103. 103: [17:14] <Rikku`on> nichts
  104. 104: [17:15] <Rikku`on> http://i.imgur.com/BHAgZ.png
  105. 105: [17:15] <Rikku`on> jetzt gehts
  106. 106: [17:15] <Rikku`on> http://i.imgur.com/fuKD2.png
  107. 107: [17:15] <jakoch> gib mal bei adminer beim Username "root" ein, alles andere leer, connected der?
  108. 108: [17:16] <Rikku`on> jetzt gehen die nicht mehr und zeigen nur noch phpinfo an
  109. 109: [17:16] <Rikku`on> http://i.imgur.com/YRYeX.png
  110. 110: [17:16] <Rikku`on> http://i.imgur.com/dFOFK.png
  111. 111: [17:16] <Rikku`on> jo, root geht
  112. 112: [17:16] <jakoch> ok..
  113. 113: [17:16] <jakoch> wie is das mit deinem cache?
  114. 114: [17:17] <jakoch> kann ich das ausschlie�en, dass es daran liegt?
  115. 115: [17:17] <jakoch> also..ich hab keine ahnung wie config.php den output von phpinfo.php erzeugen kann
  116. 116: [17:18] <jakoch> das is quasi nich m�glich ohne buffering
  117. 117: [17:18] <Rikku`on> hm... ich kann den mal löschen, aber wenn das der fall ist, ist es trotzdem ein bug :D
  118. 118: [17:20] <Rikku`on> nope, cache hat damit nichts zu tun
  119. 119: [17:22] <jakoch> hmm
  120. 120: [17:25] <jakoch> kannst du config.php (die den content von phpinfo zeigt) mal step-debuggen mit xdebug?
  121. 121: [17:28] <Rikku`on> uhm
  122. 122: [17:33] <Rikku`on> hast du denn daran etwas verändert
  123. 123: [17:33] <Rikku`on> ?
  124. 124: [17:34] <jakoch> openfile ist hinzugekommen. f�r das �ffnen der logs
  125. 125: [17:44] <jakoch> auch nach neuinstallation, kann ich die webinterface-geschichte nich reproduzieren
  126. 126: [17:47] <Rikku`on> irgendwie schient sich der server aufzuhängen wenn xdebug läuft
  127. 127: [17:47] <Rikku`on> keine ahnung warum
  128. 128: [17:48] <Rikku`on> bin mal eben essen
  129. 129: [17:48] <jakoch> ok
  130. 130: [18:43] <Rikku`on> re
  131. 131: [18:54] <Rikku`on> http://i.imgur.com/dxPx8.png
  132. 132: [18:54] <Rikku`on> danach ist der server down und muss ihn neustarten
  133. 133: [18:56] <Rikku`on> phpinfo http://i.imgur.com/93UXV.png
  134. 134: [18:56] <Rikku`on> was netbeans will http://i.imgur.com/nVh5R.png
  135. 135: [18:57] <Rikku`on> aber der server will nicht ^^
  136. 136: [18:58] <jakoch> hmm.. schwer zu sagen woran das liegt.. xdebug einstellungen sind ok, er bekommt nur keine antwort und timed dann out
  137. 137: [19:01] <jakoch> du k�nntest auch mal versuchen die debug session manuell zu starten
  138. 138: [19:01] <jakoch> also einfach den xdebug_session_start an eine url anh�ngen, netbeans muss die debug session erwarten
  139. 139: [19:01] <jakoch> die erste ist dann die, die fehlschl�gt, die zweite deine manuelle
  140. 140: [19:25] <jakoch> was sagt eigentlich das php_error.log?
  141. 141: [19:33] <Rikku`on> ähm ... mom ... muss grad hier mal was testen
  142. 142: [19:33] <Rikku`on> ist das normal das die php.ini so beschissen aussieht :D
  143. 143: [19:33] <Rikku`on> http://i.imgur.com/TkWoD.png
  144. 144: [19:34] <jakoch> nat�rlich nich
  145. 145: [19:36] <jakoch> nimm doch mal nen anderen editor
  146. 146: [19:36] <Rikku`on> hab es eben mit wamp probiert
  147. 147: [19:36] <Rikku`on> und in netbeans
  148. 148: [19:36] <Rikku`on> liegt also am stack
  149. 149: [19:37] <Rikku`on> im php_error stheht nüchts
  150. 150: [19:37] <jakoch> wamp?
  151. 151: [19:38] <Rikku`on> windows apache mysql php
  152. 152: [19:38] <jakoch> jo, des klar. was genau hast du da getestet?
  153. 153: [19:38] <Rikku`on> ob da xdebug läuft
  154. 154: [19:39] <jakoch> du k�nntest versuchen die php.ini durch php.ini-development auszutauschen
  155. 155: [19:39] <jakoch> hat wamp die gleichen versionen? php 5.4.3 und xdebug 2.2.0?
  156. 156: [19:39] <Rikku`on> nope
  157. 157: [19:39] <Rikku`on> php 5.3.10
  158. 158: [19:40] <Rikku`on> und xdebug 2.1.2
  159. 159: [19:40] <jakoch> ok, lassen wir mal xdebug aus dem spiel, einfach mal deaktiveren
  160. 160: [19:41] <jakoch> eine fehlerquelle weniger
  161. 161: [19:41] <jakoch> bleibt nginx+php und der aufruf von config.php
  162. 162: [19:42] <jakoch> uhm, also xdebug is nich gerade stabil: http://bugs.xdebug.org/view_all_bug_page.php
  163. 163: [19:43] <jakoch> werden wir sehn, obs daran liegt
  164. 164: [19:43] <jakoch> http://bugs.xdebug.org/view.php?id=810
  165. 165: [19:47] <Rikku`on> ähm ... jetzt läuft das web interface :D
  166. 166: [19:47] <Rikku`on> warum auch immer
  167. 167: [19:47] <jakoch> xdebug aus?
  168. 168: [19:48] <jakoch> krass
  169. 169: [19:48] <Rikku`on> das einzige was ich gemacht habe ist die php-ini-development ind die php.ini kopiert
  170. 170: [19:48] <Rikku`on> und server neu gestartet
  171. 171: [19:49] <Rikku`on> jo, und sieht so aus als ob da xdebuf aus ist
  172. 172: [19:49] <Rikku`on> ich check das grad mal
  173. 173: [19:49] <jakoch> na in der php devel is xdebug gar nich drin
  174. 174: [19:50] <jakoch> das is ja keine php default extension, da gibts dann nichmal nen eintrag daf�r
  175. 175: [19:50] <jakoch> und es gibt gute gr�nde, warum es keine ist^^
  176. 176: [19:50] <Rikku`on> jup... right
  177. 177: [19:50] <jakoch> der k�nnte da mal nen zweiten programmierer in dem projekt vertragen..wenn ich mir die bugliste anschaue, dann... w�rds mir keinen spass mehr machen
  178. 178: [19:51] <Rikku`on> hehe
  179. 179: [19:51] <jakoch> ich meine die ganze php community nutzt angeblich diesen debugger... warum ist da nur ein mann an einer schl�sselstelle?
  180. 180: [19:52] <Rikku`on> glaubste das der bug mit dem webinterface von xdebug kommt?
  181. 181: [19:53] <Rikku`on> hab die alte php.ini jetzt nicht mehr
  182. 182: [19:53] <Rikku`on> sonst hätte ich das nochmal getauscht und getestet
  183. 183: [19:54] <jakoch> also es wird diese php config als basis genommen
  184. 184: [19:54] <jakoch> https://github.com/jakoch/WPN-XM/blob/develop/configs/php.ini
  185. 185: [19:54] <jakoch> danach werden noch einige stellungen w�hrend der installation gemacht
  186. 186: [19:56] <jakoch> SetIniString('PHP', 'error_log', appPath + '\logs\php_error.log', php_ini_file );
  187. 187: [19:56] <jakoch> SetIniString('PHP', 'doc_root', appPath + '\www', php_ini_file );
  188. 188: [19:56] <jakoch> SetIniString('PHP', 'include_path', '.;' + appPath + '\bin\php\pear', php_ini_file );
  189. 189: [19:56] <jakoch> SetIniString('PHP', 'upload_tmp_dir', appPath + '\temp', php_ini_file );
  190. 190: [19:56] <jakoch> SetIniString('PHP', 'upload_max_filesize', '8M', php_ini_file );
  191. 191: [19:56] <jakoch> SetIniString('PHP', 'session.save_path', appPath + '\temp', php_ini_file );
  192. 192: [19:56] <jakoch> // activate remote debugging
  193. 193: [19:56] <jakoch> SetIniString('Xdebug', 'xdebug.remote_enable', 'on', php_ini_file );
  194. 194: [19:56] <jakoch> SetIniString('Xdebug', 'xdebug.remote_handler', 'dbgp', php_ini_file );
  195. 195: [19:56] <jakoch> SetIniString('Xdebug', 'xdebug.remote_host', 'localhost', php_ini_file );
  196. 196: [19:56] <jakoch> SetIniString('Xdebug', 'xdebug.remote_port', '9000', php_ini_file );
  197. 197: [19:56] <jakoch> damit werden quasi alte werte in der php ini �berschrieben
  198. 198: [19:57] <jakoch> es kann sein, dass appPath nicht richtig aufgel�st wird.. dann stimmten die pfadangaben nicht
  199. 199: [19:57] <jakoch> und dadurch kann php auch crashen
  200. 200: [19:58] <jakoch> bei mir is das allerdings alles korrekt:
  201. 201: [19:58] <jakoch> error_log =i:\server-test-rc\logs\php_error.log
  202. 202: [19:59] <jakoch> uhm.. mal abgesehn, von einer miesen sache: include_path, upload_tmp und session.save_path landen im bereich der extensions
  203. 203: [19:59] <jakoch> aber das geh�rt alles noch zur [PHP] section und sollte daher keinen fehler verursachen
  204. 204: [20:00] <jakoch> brb -> essen
  205. 205: [20:03] <Rikku`on> so ich glaub ich hab die richtung
  206. 206: [20:04] <Rikku`on> es ist apc
  207. 207: [20:04] <Rikku`on> apc aus -> webinterface alles supi
  208. 208: [20:04] <Rikku`on> apc an -> webinterface evil
  209. 209: [20:23] <jakoch> da schau an
  210. 210: [20:24] <jakoch> https://bugs.php.net/search.php?search_for=apc&boolean=0&limit=50&order_by=&direction=DESC&cmd=display&status=All&bug_type=All&project=All&php_os=&phpver=5.4.0&cve_id=&assign=&author_email=&bug_age=0&bug_updated=0
  211. 211: [20:34] <jakoch> beim apc stell ich um auf installieren ohne ini eintrag
  212. 212: [20:42] <Rikku`on> aber wie apc mit dem webinterface ding da so zusammenhängt ist mir unklar
  213. 213: [20:44] <jakoch> naja, cache is cache :) immerhin kam der content ja sehr schnell, wenn auch der falsche
  214. 214: [20:44] <Rikku`on> hehe...lol
  215. 215: [20:45] <jakoch> ok, apc is off, kann vom user angestellt werden, die off-eintr�ge sind vorhanden
  216. 216: [20:45] <jakoch> geht bei dir �ffnen von logs ausm webinterface?
  217. 217: [20:48] <Rikku`on> jup
  218. 218: [20:48] <jakoch> na das is doch schonmal was
  219. 219: [20:48] <Rikku`on> mir fällt gerade etwas auf
  220. 220: [20:49] <Rikku`on> bin mir aber nicht sicher ob das so gehört ?!?
  221. 221: [20:49] <Rikku`on> der php-fpm hört auf port 9000
  222. 222: [20:49] <Rikku`on> dann kann xdebug nicht auch darauf seine lauscher haben
  223. 223: [20:50] <Rikku`on> oder müßen beide den gleichen haben?
  224. 224: [20:50] <jakoch> nein
  225. 225: [20:50] <jakoch> gut gesehn
  226. 226: [20:50] <jakoch> stimmt: php-cgi.exe -b 127.0.0.1:9000
  227. 227: [20:52] <jakoch> dann geh ich auf 9100
  228. 228: [20:53] <jakoch> netbeans schl�gt ja immer 9000 f�r xdebug vor
  229. 229: [20:53] <Rikku`on> jup
  230. 230: [21:01] <jakoch> ehhh...
  231. 231: [21:01] <jakoch> ich habs gefunden
  232. 232: [21:02] <jakoch> "delete trayIcon;" im destructor
  233. 233: [21:02] <jakoch> rofl
  234. 234: [21:02] <jakoch> verdammte axt
  235. 235: [21:02] <jakoch> qt===weird
  236. 236: [21:06] <Rikku`on> ^^
  237. 237: [21:16] * wpnxm-bot (~wpnxm-bot@sh3.rs.github.com) has joined #clansuite
  238. 238: [21:16] <wpnxm-bot> [WPN-XM] jakoch pushed 10 new commits to develop: https://github.com/jakoch/WPN-XM/compare/e5d248c...0727275
  239. 239: [21:16] <wpnxm-bot> [WPN-XM/develop] fixed "expand "app" constant before it was initialized" bug - jakoch
  240. 240: [21:16] <wpnxm-bot> [WPN-XM/develop] added WPN-XM SCP v0.3.0 as component - jakoch
  241. 241: [21:16] <wpnxm-bot> [WPN-XM/develop] typo - jakoch
  242. 242: [21:16] * wpnxm-bot (~wpnxm-bot@sh3.rs.github.com) has left #clansuite
  243. 243: [21:19] <Rikku`on> sag mal muss xdebug nicht als zend_extension geladen werden
  244. 244: [21:20] <jakoch> ja
  245. 245: [21:21] <jakoch> SetIniString('Zend', 'zend_extension', appPath + '\bin\php\ext\php_xdebug.dll', php_ini_file );
  246. 246: [21:21] <jakoch> mach ich auch so
  247. 247: [21:22] <jakoch> http://clansuite.com/ftp/wpn-xm-scp-0.3.0.zip
  248. 248: [21:23] <jakoch> neue version: ohne icon problem beim shutdown, leds aus
  249. 249: [21:25] <jakoch> maria sollte auch starten
  250. 250: [21:25] <Rikku`on> neues setup auch?
  251. 251: [21:25] <jakoch> nein, da such ich noch den wpnscp unzip fehler
  252. 252: [21:25] <Rikku`on> wo das scp gleich mit geladen wird?
  253. 253: [21:26] <jakoch> da is irgendwas mit dem pfad falsch, download is ok, aber auspacken geht fehl
  254. 254: [21:26] <Rikku`on> dann guck mal, hab nämlich eben gerade schon die installation gelöscht, weil ich dachte der link wäre ein neues setup
  255. 255: [21:26] <Rikku`on> war es aber nicht
  256. 256: [21:26] <Rikku`on> :D
  257. 257: [21:28] <jakoch> uhm.. zip level?
  258. 258: [21:30] <jakoch> "unsupported compression method 14"
  259. 259: [21:30] <jakoch> klasse
  260. 260: [21:30] <jakoch> lol
  261. 261: [21:31] <Rikku`on> ^^
  262. 262: [21:31] <jakoch> d.h. der installer hat keinen fehler
  263. 263: [21:31] <jakoch> nur die zip datei ist etwas zu strong eingepackt
  264. 264: [21:32] <jakoch> http://clansuite.com/ftp/WPNXM-0.3.0-Setup.exe
  265. 265: [21:57] <jakoch> wenn man versucht php mehrmals zu starten, sollte dann kommen: "PHP already running."
  266. 266: [21:57] <jakoch> das dient dazu prozess-dopplungen zu vermeiden..hoffe das funzt
  267. 267: [21:58] <jakoch> "maria crashed beim shutdown"
  268. 268: [21:59] <jakoch> afk
  269. 269: [22:14] <Rikku`on> re
  270. 270: [22:14] <Rikku`on> sry, war gerade abendbrot essen
  271. 271: [22:14] <Rikku`on> ich teste mal
  272. 272: [22:15] <Rikku`on> bei der installation kam immer noch nich der fehler das mysql den angegebenen dateinamen nicht finden kann
  273. 273: [22:15] <Rikku`on> scp ist immernoch nicht drin
  274. 274: [22:18] <Rikku`on> beim starten von php
  275. 275: [22:18] <Rikku`on> http://i.imgur.com/pXCgh.png
  276. 276: [22:19] <Rikku`on> maria läßt sich immernoch nicht starten
  277. 277: [22:19] <Rikku`on> php/nginx already running funzt
  278. 278: [22:20] <Rikku`on> tray icon verschwindet nach quit - funzt
  279. 279: [22:20] <Rikku`on> stati aus wenn scp start - funzt
  280. 280: [22:22] <Rikku`on> php.ini immer noch unlesbar
  281. 281: [23:24] <jakoch> re
  282. 282: [23:24] <jakoch> ok, dann muss noch ein weiterer dateiname beim mysql l�schen falsch sein
  283. 283: [23:26] <jakoch> das SCP ist nich im hauptverzeichnis?
  284. 284: [23:27] <jakoch> ah... halt
  285. 285: [23:28] <jakoch> falscher ftp.. nich der von clansuite, sondern wpn.. kann nich gehn
  286. 286: [23:30] <jakoch> ok, SCP download ist nun richtige zip
  287. 287: [23:34] <Rikku`on> ok, ich teste nochmal
  288. 288: [23:36] <jakoch> memcached muss ich auch abschalten, die version geht nicht mit 5.4.3
  289. 289: [23:37] <jakoch> und dann m�ssen wir mal drauf achten, dass die titelzeile vom SCP nicht @APP_VERSION@ sondern die versionsnummer enth�lt
  290. 290: [23:39] <Rikku`on> so, scp ist drin
  291. 291: [23:39] <Rikku`on> und im title steht @APP_VERSION@
  292. 292: [23:39] <jakoch> argz
  293. 293: [23:39] <jakoch> http://i.imgur.com/pXCgh.png
  294. 294: [23:40] <jakoch> sag mal, die php api nummer, die stimmt doch nich.. 2010? 05= 25?
  295. 295: [23:40] <jakoch> muss das nich 20120525 sein?
  296. 296: [23:41] <Rikku`on> kein plan
  297. 297: [23:41] <jakoch> nee, is richtig: PHP compiled with module API=20100525
  298. 298: [23:43] <Rikku`on> memcache ist doch in der php.ini auskommetiert, wiso kommt den da der fehler?
  299. 299: [23:43] <jakoch> gibt bestimmt zwei eintr�ge
  300. 300: [23:44] <Rikku`on> schwer zu finden ^^
  301. 301: [23:47] <Rikku`on> ja, war ein zweiter eintrag
  302. 302: [23:47] <Rikku`on> aber mittlerweile läuft der server nicht mehr
  303. 303: [23:47] <Rikku`on> :D
  304. 304: [23:48] <jakoch> SetIniString... is irgendwie nicht nett zu der php.ini
  305. 305: [23:48] <Rikku`on> php-fpm.exe und nginx.exe laufen, aber localhost/webinterface gibt mir eine 404 zurück
  306. 306: [23:49] <Rikku`on> also immerhin 404, das heißt nginx läuft
  307. 307: [23:49] <Rikku`on> aber php nicht?
  308. 308: [23:50] <jakoch> ja...�hm.. jetzt haben wir php-cgi auf port 9100, aber nginx wei� das noch nicht^^
  309. 309: [23:50] <jakoch> nginx.conf
  310. 310: [23:51] <jakoch> da gibt es ne direktive.... fastcgi_pass 127.0.0.1:9100;
  311. 311: [23:51] <Rikku`on> besser ;-)
  312. 312: [23:52] <jakoch> ok, das mit den ports nervt.. da muss unbedingt in der n�chstens version die wpn-xm.ini her
  313. 313: [23:52] <jakoch> dann kann ich die eingestellten ports dort auslesen und in allen dateien setzen
  314. 314: [23:52] <Rikku`on> das macht sinn
  315. 315: [23:53] <jakoch> dann kann auch der SetIniString kram wieder aus dem installer, der zerschie�t nur die php.ini
  316. 316: [23:53] <Rikku`on> das macht er verdammt gut ^^
  317. 317: [23:53] <jakoch> ja, find ich auch. verdammt gute leistung f�r ein pascal programm :)
  318. 318: [23:54] <Rikku`on> werden die scp stati nur getriggert auf dem start/stop button?
  319. 319: [23:54] <Rikku`on> oder werden die zwischendurch auch einfach mal abgefragt
  320. 320: [23:54] <jakoch> also im moment ist das so
  321. 321: [23:55] <jakoch> wenns die prozesse schon vorher gibt, dann wird das im moment leider nicht erkannt
  322. 322: [23:55] <Rikku`on> jo, darauf wollte hinaus
  323. 323: [23:56] <jakoch> wenn die prozesse vom scp gestartet werden, dann sind sie auch unter prozessmonitoring, d.h. wenn du sie manuell abschie�t, dann sollte da eine messagebox kommen mit der merldung process crashed while running
  324. 324: [23:56] <jakoch> das gleiche sollte kommen, wenn php-cgi einfach so die hufe hochrei�t
  325. 325: [23:57] <Rikku`on> gibt es in windows keine events, also das du dich für das event proccess nginx.exe registriert, und wenn die exe im system ist, dann ein event feuert, das du eine notification im programm erhhältst?
  326. 326: [23:57] <jakoch> das is nich so einfach mit der prozess�berwachung...
  327. 327: [23:58] <Rikku`on> ok, hab ich auch kein plan von, wäre nur ne idee
  328. 328: [23:58] <jakoch> c++ seitig k�nnte man auf psapi.h gehen... und dann �ber EnumProcesses() die liste der prozesse durch, dann den namen rauspicken und unter �berwachung stellen
  329. 329: [23:59] <jakoch> qt hat leider keine funktionen daf�r im framework
  330. 330: [23:59] <jakoch> es gibt eine m�glichkeit das �ber die console zu machen

Links of Montag, 11. Juni 2012

1) http://i.imgur.com/pXCgh.png
2) http://clansuite.com/ftp/WPNXM-0.3.0-Setup.exe
3) http://clansuite.com/ftp/wpn-xm-scp-0.3.0.zip
4) https://github.com/jakoch/WPN-XM/compare/e5d248c...0727275
5) https://bugs.php.net/search.php?search_for=apc&boolean=0&limit=50&order_by=&direction=DESC&cmd=display&status=All&bug_type=All&project=All&php_os=&phpver=5.4.0&cve_id=&assign=&author_email=&bug_age=0&bug_updated=0
6) https://github.com/jakoch/WPN-XM/blob/develop/configs/php.ini
7) http://bugs.xdebug.org/view.php?id=810
8) http://bugs.xdebug.org/view_all_bug_page.php
9) http://i.imgur.com/TkWoD.png
10) http://i.imgur.com/nVh5R.png
11) http://i.imgur.com/93UXV.png
12) http://i.imgur.com/dxPx8.png
13) http://i.imgur.com/dFOFK.png
14) http://i.imgur.com/YRYeX.png
15) http://i.imgur.com/fuKD2.png
16) http://i.imgur.com/BHAgZ.png
17) http://i.imgur.com/SoKc5.png
18) http://i.imgur.com/8KcJZ.png
19) http://i.imgur.com/K0YS1.png
20) http://i.imgur.com/ZxDkO.png
21) http://wpn-xm.org/files/wpn-xm-scp-0.3.0.zip
22) https://github.com/downloads/jakoch/WPN-XM/WPNXM-0.3.0-Setup.exe
23) https://github.com/jakoch/WPN-XM/commit/e5d248cbb91a0c00a48e025aa4a79d68a034f98a
24) http://codepad.org/d0kWPZvi
25) http://de.wikipedia.org/wiki/Polyphasischer_Schlaf
26) https://github.com/jakoch/WPN-XM/compare/3d5eaef...09b5ab5
27) https://github.com/jakoch/WPN-XM/commit/3d5eaef33a4f3f6330feaa5bc704db1ea1bbc091
28) https://github.com/jakoch/WPN-XM/issues

These logs were automatically created by k-logbot on chat.freenode.net using the Clansuite IRC LogBot. Find the project at Github.